The best way to deploy Mr CMS

Jan 8, 2015 at 3:02 PM
Hello,

I use publish method "File System". Then I move all files to web Server. Then I start URL and get ERR_TOO_MANY_REDIRECTS. What I'm doing wrong?

Thanks,
Art

PS: Thank to Will for his answer, but it didn't help [https://mrcms.codeplex.com/workitem/73
Coordinator
Jan 8, 2015 at 3:05 PM
Have you uploaded your App_Data folder with the published files?

Have you updated your connection string?

Finally, make sure in the Sites database table the site URL is configured to the live URL. For example, if www.art.com is you domain make sure this is input in the field.
Coordinator
Jan 8, 2015 at 3:38 PM
I saw your answer on the issue:
I'm included App_Data to solution, so it published automatically, so:
Connection string is the same like in VS
"Sites database table the site URL": it is on my test-machine localhost/mrcms
If you want, add me on Skype and we can screen share - I will try and help out that way. Screen Name thought.will
Jan 8, 2015 at 4:43 PM
Thanks a lot. I try it now on this way, if we have no success, I will contact you per skype.

My developer machine: WIN 8.1, VS 2013 PRO, SQL EXPRESS 2012.

After setup, we have web project settings:
Project URL: http://localhost:1834/ (IIS Express) __Web.Config__:<connectionStrings configSource="ConnectionStrings.config" />
mrcms.settings.databasesettings.json: connection string to Database

I start the projegt in Visual Studio with named setting - my lovely MrCMS works fine.

But now I want to develop my MrCMS project in the context of local IIS and change setting to "Local ISS"
Project URL: i change it from http://localhost:1834/ to http://localhost/MrCMS I get the message from Visual Studio: _"Unable to open conficSource file 'ConnectionStrings.config' (C:..\web.config line 25)" (***)_.
  • Why this? ... ok go further, I click to "OK", save project settings. And change next step
    DB.Table Site, Field [BaseUrl]: localhost/MrCMS
  • I start my project in debug mode and get the same message (***), make the same procedure - OK.
    Fiddler: HTTP/1.1 302 Found
Cache-Control: private
Content-Type: text/html; charset=utf-8
Location: /MrCms/
Server: Microsoft-IIS/8.5
X-Built-With: Mr CMS - http://www.mrcms.com
X-AspNet-Version: 4.0.30319
X-Powered-By: ASP.NET
Date: Thu, 08 Jan 2015 16:34:04 GMT
Content-Length: 124

<html><head><title>Object moved</title></head><body>
<h2>Object moved to <a href="/MrCms/">here</a>.</h2>
</body></html>
SQL ServerProfiler : Nothing. The call don't riched SQL Server. The same case is it when I deploy like I described before.

I hope you can reproduce this.

By the way, I develop most time with Local IIS, not with IIS Express and it is good, because this is similar to my target environment.

Thanks,
Art
Coordinator
Jan 8, 2015 at 4:58 PM
Mr CMS does require route application at the moment. I.E /.

However, you can still do this with IIS if you want. Just set it as so:

Image

You'll need to run VS as an administrator.
Marked as answer by thought on 1/8/2015 at 11:23 AM
Jan 8, 2015 at 6:55 PM
Thank you very much!!! It works.

Mr CMS does require route application at the moment. I.E /. : Are there any plans to change this in future?
Coordinator
Jan 8, 2015 at 7:23 PM
Potentially, although Mr CMS is aimed to be a one stop shop for any need (ecommerce, blogs, publishing etc). Therefore we see Mr CMS always being a route application.