This project is read-only.

ckeditor does not have font style, size and color

May 21, 2014 at 10:51 AM
ckeditor does not have font style, size and color options. How to show complete toolbar?
May 21, 2014 at 10:58 AM

In System -> Settings -> Site Settings tab there is a CKEditor config. You can simply add/remove functionality from CKEditor here.
May 21, 2014 at 11:20 AM
Please provide code for font family, size and color. Changes done in setting is not working.
May 21, 2014 at 11:35 AM
You will need to download the addon and put in your plugins folder:

Just so you know how this works - the setting field where you set up CKEditor in System -> Settings -> Site Settings tab is rendered out to We then use this config for the ckeditor through admin.

If you want to add plugins which don't already exist you will need to add them to /Areas/Admin/Content/Editors/ckeditor/plugins folder.

You should just be able to download the Font addon as above, add to the folder and it will work so long as you have added it to the config file.
May 21, 2014 at 1:06 PM
I downloaded the addon 'font' from Added to the folder /Areas/Admin/Content/Editors/ckeditor/plugins.

Added 'font': 1, 'color': 1, in file /Areas/Admin/Content/Editors/ckeditor/build-config.js

Also, in System -> Site Settings -> in ckeditor config added { name: 'styles', items: ['Format', 'Styles','Font', 'FontSize','Color'] } / [Font]
                                              added  config.extraPlugins = 'font'
but nothing is working. Please help.
May 21, 2014 at 2:00 PM
What is build-config.js ?

You don't need to replace the config file, it is auto generated from the settings - remove build-config and just use the inbuilt paths.
May 21, 2014 at 2:06 PM
In fact, you should make sure there is no file in this location or it won't work: /Areas/Admin/Content/Editors/ckeditor/config.js.
May 22, 2014 at 6:53 AM
All options are coming in editor. Thanx !!!